ChatGPT Enterprise Audit Logs Missing After Dec 16
Resolved
Dec 17 at 05:12pm PST
Incident Timeline:
[Dec 17, 2025 - Initial Detection]
Identified missing ChatGPT Enterprise audit logs for Opsin's own tenant in our monitoring platform. Investigation began to determine root cause.
[Dec 17, 2025 - Investigation]
Confirmed our data ingestion pipeline is functioning correctly
Verified the outage only affects Opsin's ChatGPT tenant and not customer tenants.
Verified OpenAI compliance API returns data for timestamps before Dec 16 (e.g., 1765777246) but returns empty results for Dec 16 onward (1765885391+)
Confirmed users actively used ChatGPT during the affected period
[Dec 17, 2025 - Root Cause Identified]
Issue confirmed as upstream bug in OpenAI's compliance API. Opened support ticket with OpenAI including workspace details, timestamp examples, and API evidence.
[Dec 17, 2025 - Mitigation]
Widening our lookback window configuration to prevent future gaps
Documented affected time period (Dec 16 onward) for compliance records
Prepared backfill process pending OpenAI data restoration
[Dec 17, 2025 - OpenAI Confirmation]
OpenAI support confirmed this is a known bug. Their engineering team is actively working on a fix. Awaiting resolution and data backfill.
[Dec 18, 2025 - Resolve issue as tenant specific]
Since the issue is specific to Opsin's only ChatGPT tenant we will work with OpenAI to resolve the issue in our environment. We've determined there is no customer impact at this time or for this issue.
Affected services